Deposit and Withdrawal: Service Degraded

Incident Report for Deriv

Resolved

The issue has been resolved, and all systems are fully operational.
Posted Jul 14, 2025 - 09:13 GMT

Monitoring

A fix has been implemented and is being monitored to ensure stability and performance. We will share updates once the issue is confirmed to be fully resolved
Posted Jul 14, 2025 - 08:47 GMT

Identified

We are currently experiencing unexpected technical difficulties with our system. Our team is investigating and will provide further updates as progress is made.
Posted Jul 14, 2025 - 08:36 GMT
This incident affected: Cashier payment services.