WhatsApp Service Degraded

Incident Report for Deriv

Resolved

This incident has been resolved.
Posted May 26, 2025 - 14:39 GMT

Identified

We are experiencing technical issues with our WhatsApp communication channel, which is temporarily unavailable.

For immediate live support, please use the live chat option on our website at deriv.com, or email us at support@deriv.com. We apologize for any disruption this may cause.
Posted May 20, 2025 - 10:15 GMT