Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 05, 2025 - 05:00 GMT
Scheduled
Spotware, the developer of cTrader, will be performing monthly maintenance to enhance your trading experience.
What to expect: 1. Trading synthetics and cryptocurrencies in Deriv cTrader might experience a brief interruption for about 5 minutes during maintenance window. 2. Internal transfers won’t be affected. 3. The Deriv cTrader dashboard will be temporarily unavailable during the expected brief interruption period. Trading, deposits, and withdrawals won’t be possible on your Deriv cTrader account during this time.
What you should do: 1. Review and manage your open positions before maintenance begins. 2. Modifying or closing positions on Deriv cTrader won’t be possible during the brief interruption period.
Our cTrader will be back online as soon as maintenance is complete.
Posted Jul 03, 2025 - 04:03 GMT
This scheduled maintenance affected: cTrader Services.